Poor 2D performance with linux radeon driver

Discussions related to the BloodsPilot clients
Angeba
Posts: 88
Joined: Sun Feb 06, 2011 11:23 pm

Poor 2D performance with linux radeon driver

Postby Angeba » Sun Apr 13, 2014 2:42 pm

I have unplayable 2D performance with the free radeon driver (xserver-xorg-video-radeon 6.14.4-8)
on debian 7 wheezy linux (both on amd athlon64x2, Radeon HD 4350 and amd A8 with integrated radeon gfx)
WITH driver option `NoAccel' = `False' (i.e. WITH 3D acceleration enabled).
But if I disable 3D acceleration (`NoAccel' = `True'), then 2D performance is okay.

That is with 3D acceleration, the client draws about 25/50 frames with client lag of 20 to 50 ms.
Without 3D acceleration, it draws the full 50 frames with client lag between 5 and 10 ms.

I also tried a newer radeon driver (7.x from testing iirc), but it performed no better.

Until the driver improves, the workaround for me is to use a custom `/etc/X11/xorg.conf',
which defines an additional screen without 3D acceleration, which I use on another X-display for
the Xpilot client.

The relevant parts of my xorg.conf are:

Code: Select all

...
Section "Device"
        # radeon driver with options optimized for good 2d performance (xpilot)
        Identifier      "radeon-2d"
        Driver          "radeon"
        BusID           "PCI:4:0:0"

        # NoAccel=True results in better 2d performance, but unusable 3d
        # with current radeon driver (xserver-xorg-video-radeon Version: 1:6.14.4-8 (2014-02).
        Option          "NoAccel"       "True"
EndSection
...
Section "Screen"
        Identifier "Screen2d"
        Device          "radeon-2d"
        Monitor         "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
...


With this I can start the Xpilot display from another virtual terminal like:
startx $(which xterm) -- $(which X) -screen Screen2d :1
Then start window manager and bloodspilot client.
x-window-manager &
bloodspilot-client-x11

rotunda
Site Admin
Posts: 77
Joined: Wed Mar 24, 2010 2:19 pm

Re: Poor 2D performance with linux radeon driver

Postby rotunda » Sat Apr 19, 2014 11:09 pm

Just curious, could you try the performance in the SDL client while 3D acceleration is on?

Angeba
Posts: 88
Joined: Sun Feb 06, 2011 11:23 pm

Re: Poor 2D performance with linux radeon driver

Postby Angeba » Fri May 02, 2014 9:37 am

The SDL-client is fast with 3D acceleration enabled and relatively slow without 3D acceleration.

NB: There seems to be no option in the sdl client to disable textures on items and shots.
I dislike textures in xpilot, because they distract. And especially with higher scalefactor
one cannot recognize textured items.
Also gravity fields, wormholes, targets etc. are so ugly with textures.

rotunda
Site Admin
Posts: 77
Joined: Wed Mar 24, 2010 2:19 pm

Re: Poor 2D performance with linux radeon driver

Postby rotunda » Mon May 05, 2014 9:10 pm

Glad that it works. As for disabling textures, I started doing it, e.g. for treasure chests. I would like to finish it sometime.


Return to “BloodsPilot Clients”

Who is online

Users browsing this forum: No registered users and 1 guest