client performance in Xfree/Xorg

Discussions related to the BloodsPilot clients
Coppa
Posts: 3
Joined: Wed Mar 24, 2010 2:57 pm

client performance in Xfree/Xorg

Postby Coppa » Tue Apr 06, 2010 7:53 pm

I have used x11perf -line500 to test for 2d drawing speed for lines in X. When you test with this, turn off all disturbing applications and audio. Report the last line, which is the average over 5 measurements.

Some of my results:
200 Mhz Pentium MMX with ATI 1 Mb gfx card (1024x768x8bit):
26800.0 lines/sec
300 Mhz PII with Voodoo2 Banshee (1280x1024x16bit):
around 70000.0 lines/sec (around 30000 without gfx acceleration)
300 Mhz PII with Geforce 2 (1280x1024x16bit):
210000.0 lines/sec

All results on Xfree versions 4.0-around 4.3

rotunda
Site Admin
Posts: 77
Joined: Wed Mar 24, 2010 2:19 pm

Re: client performance in Xfree/Xorg

Postby rotunda » Tue Apr 06, 2010 8:03 pm

I get:
15000000 trep @ 0.0021 msec (477000.0/sec): 500-pixel line

The card is:
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 135M (rev a1)

Runtime environment:
64-bit Linux kernel 2.6.31.6
xorg-server 2:1.6.4-2ubuntu4.1
nvidia proprietary graphics driver version 185.18.36
display parameters: 1440x900@24bit

Samaseon
Posts: 13
Joined: Wed Mar 24, 2010 2:47 pm

Re: client performance in Xfree/Xorg

Postby Samaseon » Tue Apr 06, 2010 8:09 pm

4000000 reps @ 0.0015 msec (655000.0/sec): 500-pixel line
VGA compatible controller: nVidia Corporation GeForce 7600 GT (rev a2)
I'm using Nvidia's own driver.

Resolution is 1280x960 with 24 bits of depth.

X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-10.lenny2)
Current Operating System: Linux optimus 2.6.26-2-686 #1 SMP Tue Mar 9 17:35:51 UTC 2010 i686

taras
Posts: 5
Joined: Wed Mar 24, 2010 7:19 pm

Re: client performance in Xfree/Xorg

Postby taras » Wed Apr 07, 2010 11:53 pm

400000 reps @ 0.0122 msec ( 81900.0/sec): 500-pixel line
On my laptop (1) with intel video, should be much better, due to bugs in intel xorg driver in Debian Lenny.
I think one of my old machines (2) with NVidia Vanta Lite 16 MB did better :)

Same on another laptop (3) with intel video and lenny:
400000 reps @ 0.0131 msec ( 76200.0/sec): 500-pixel line

2000000 reps @ 0.0046 msec (220000.0/sec): 500-pixel line
On old machine(2.4 GHz Celeron times) with NVidia GeForce FX5200 128 MB (4)

glxgears for results for (1) and (3)
4164 frames in 5.0 seconds = 832.710 FPS

3098 frames in 5.0 seconds = 619.570 FPS

for machine (4) around 900-1000 FPS

sloopy
Posts: 3
Joined: Wed Mar 24, 2010 5:40 pm

Re: client performance in Xfree/Xorg

Postby sloopy » Mon Apr 19, 2010 8:32 pm

i have twinview running...

left display (primary)
4500000 trep @ 0.0067 msec (150000.0/sec): 500-pixel line
right display (secondary)
4500000 trep @ 0.0061 msec (165000.0/sec): 500-pixel line

interesting considering they are two outputs on same card... nVidia G-Force FX 5200
res is 1280x1024 on both (17" CRT's)

AMD Sempron 3400+ x64
Ubuntu 9.10 box (32bit)
X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux amy 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.31-20-generic root=UUID=7619e71d-f099-4eda-90e4-d044982a5584 ro quiet splash
Build Date: 04 March 2010 09:56:47AM
xorg-server 2:1.6.4-2ubuntu4.2 (buildd@)


sloopy.


Return to “BloodsPilot Clients”

Who is online

Users browsing this forum: No registered users and 1 guest